java技术圈 为您找到相关结果 16

Rancher部署kubernetes爬坑记

引言: 本文不会记录详细的部署过程,仅记录下使用Rancher部署kubernetes踩过的几个小坑,如果你需要详细的部署过程,可以参考此处官方教程,这里面有详细的部署说明,另外可同时参考下此文,也许对你在部署中遇到的问题有所帮助。由于个人能力有限,如有不当之处,欢迎指正。 环境 一台ubuntu 16.04 服务器 作为Rancher Server 宿主机,并且加入k8s集群 一台virtualbox 虚拟的centos 7.3 服务器,并且加入k8s集群 localhost 问题 问题描述:在安装好Rancher server,以及新建k8s环境后,需要在k8s中添加主机节点host,按照描述在需要加入的节点中运行,结果报错: requests.exceptions.Connection...阅读全文

博文 2019-04-04 17:54:39 www.allocmem.com

maven手动安装远程仓库中找不到的jar到本地仓库

只需要使用一个maven命令即可: mvn install:install-file -Dfile=(jar本地地址)/root/IdeaProjects/keta-customer/lib/patchca-0.5.0.jar -DgroupId=com.github.bingoohuang(groupId) -DartifactId=(artifactId)patchca -Dversion=(version)0.5.0 -Dpackaging=jar 即可利用pom像普通情况一样使用,在项目里自由使用了 后来因需安装bairong jar 使用命令: mvn install:install-file -Dfile=/Users/daniel/Desktop/bsApi-2.3.5-sha...阅读全文

博文 2019-04-04 17:45:57 www.allocmem.com

mongo 3.0 备份和还原数据库

主要记录下在mongo 3.0的操作 ####备份示例 ./mongodump -h localhost -d liongo -o ./ #####还原示例 错误方式: ./mongorestore -h 127.0.0.1 -d liongo --directoryperdb /home/zhoudazhuang/company-zhoudazhuang/liongo/note.bson 会报错: 2017-01-27T15:31:54.217+0800 error parsing command line options: --dbpath and related flags are not supported in 3.0 tools. See http://dochub.mongod...阅读全文

博文 2019-04-04 17:49:36 www.allocmem.com

spring4 配置json *.html 出现HTTP 406问题

引起原因: spring4.x中原请求servlet-mapping为/ 拦截所有请求 需要修改为*.html,需使用spring4.x 重现: 原本是直接修改servlet-mapping /改位*.html 结果:修改为*.html过后 请求无法正常发挥Json,一直报错htpp 406 无法接受的请求头 寻找问题并解决过程: 发现spring-servlet.xml的xsi原始指向位spring3.x 果断修改为4.x 后来干脆直接删掉后缀,如下: 阅读全文

博文 2019-04-04 17:47:29 www.allocmem.com

archlinux下网易云音乐netease-cloud

个人为网易云音乐重度用户,从ubuntu到arch后,感觉netease-cloud-music仍然在ubuntu中支持更好,毕竟linux下的netease-cloud-music是由网易云音乐和深度deepin联合开发的,ubuntu有官方的deb包,arch的aur中的netease-cloud-music是基于此deb进行打包的,在体验上没有差别,在arch中用起来感觉也还不错,在此记录下使用过程中遇到的问题以及解决方式,本文会不定时更新 1. 启动报错,客户端无法打开 这个问题具体报错记不清了,问题为点击无法打开,命令行运行报错,后来在AUR上看到,在命令行上使用 –no-sandbox 关闭沙箱运行,则可正常使用 2. 这个问题有点坑,在用了一段时间后,发现网易云音乐再次无法打开...阅读全文

博文 2019-04-04 17:54:58 music部分问题

jottings

安装环境: ubuntu 16.04 LTS 一台待克隆的计算机,一台原始ubuntu16.04计算机 安装过程: 1. 在新的计算机中安装好ubuntu16.04 LTS(这篇文章主要介绍系统的克隆,对于初始安装这里不再赘述,所有操作请确保自己拥有root权限) 2. 使用tar压缩源计算机的相关文件(包括配置,软件,文件等) tar -zcpPf /media/zhoudazhuang/NEWSMY/ubuntu.tar.gz --exclude=/proc --exclude=/lost+found --exclude=/media/zhoudazhuang/NEWSMY/ubuntu.tar.gz --exclude=/media --exclude=/mnt --exclude=/...阅读全文

博文 2019-04-04 17:48:33 ubuntu16.04 lts的完整克隆

java构造函数以及static关键字

java构造函数以及static关键字 Author anteoy@gmail.com | Posted 2017-01-03 11:41:00 ###关于java构造器 原本无显示编码构造器,则有一个默认的隐式(隐藏的无参构造器),但是,当显示指定了构造器,则这个默认隐式的构造器将不存在,比如此时无法new无参的构造器(除非显示地编写声明无参的构造函数)。如下: “` package com.anteoy.coreJava.constructor; /** Created by zhoudazhuang Date: 17-1-3 Time: 上午10:46 Description : */ public class TestObj { public TestObj(){ } public ...阅读全文

博文 2019-04-04 17:49:08 www.allocmem.com

ubuntu 16.04 解决有线网卡驱动Exec format error问题

前言 ubuntu 16.04的工作本,有线网卡总是出一些比较坑的问题,比如有时候能用有时候突然又不能用了,有时候开机没问题正常使用,有时候开机完全找不到有线连接,同时,个人使用习惯会经常休眠,而休眠唤醒过后,有线网就肯定不能用了.原本比较少用有线网络,这个工作本的有线网络也没有怎么管它.另外这个本也有好几年了,原本以为是网卡接口接触不良,最近公司的无线网络越来越难用,越来越慢,于是就好好看了下这个有线网卡的问题. 驱动问题 稍做检查,发现是ubuntu在安装的时候,默认装的驱动居然不是最适配的驱动(最后发现这是一个坑,因为我手动也无法装上官网最适合的驱动,估计ubuntu发现自己无法装最适合的,自主切换为另一个有问题的驱动) lspci -v 0e:00.0 Ethernet contro...阅读全文

博文 2019-04-04 17:56:54 www.allocmem.com

opensuse下安装网易云音乐netease-cloud

opensuse下安装网易云音乐netease-cloud-music Author anteoy@gmail.com | Posted 2017-10-04 22:49:00 安装过程 安装环境 opensuse 42.3(理论上仓库中列出的支持版本都可以用此方法安装) 官方软件仓库搜索netease,也可直接点击此处打开:https://software.opensuse.org/package/netease-cloud-music?search_term=netease 选择对应版本,点击Source下载源码,我这里下载的对应版本为42.3,得到如下文件(注意这里点击1 Click Install安装会出错,我最开始点击直接安装,结果提示安装成功,但无法使用,仔细看安装日志会发现,虽...阅读全文

博文 2019-04-04 17:55:08 music

GO语言中封装,继承,和多态

##封装 go中的封装和java的不太一样,在go里面是没有java中的class,不过可以把struct看成一个类,封装可以简单地看作对struct的封装,如下 ``` type obj1 struct { valte1 string } type obj2 struct { valte2 string } ``` ##继承 把struct看做类,struct中可以包含其他的struct,继承内部struct的方法和变量,同时可以重写,代码如下 ``` package main import "fmt" type oo struct { inner ss1 string ss2 int ss3 bool } type inn...阅读全文

Mac下MySQL中LOAD DATA INFILE出现The used command is not allowed with this MySQL version问题_数据库_AeroZhou

解决“LOAD DATA local INFILE”时出现The used command is not allowed with this MySQL version问题 09-07 阅读数 6440 “LOAD DATA local INFILE”时出现The used command is not allowed with this MySQL version问题。第一是版本确实过低,低于5.0... 博文 来自: ziyou434的博客 使用HeidiSQL连接Mysql数据库:导入本地csv文件,报错解决方法 02-16 阅读数 1241 第一次使用HeidiSQL连接MySQL,数据库连接成功后,进行csv文件的导入。本地文件存储于:尝试在heidiSQL中采用导入csv加载本地...阅读全文

博文 2020-04-24 16:13:46 CSDN博客

如何解决java.lang.SecurityException: Invalid signature file digest for Manifest main attributes_tongtong0704的博客

这个问题是在maven打包之后由于重复引用某些依赖导致生成了一些.SF等文件,运行jar时会抛出。 在遇到这个问题时,一时不知道是什么原因,上网查了很多解决方法,有的回答是: 原因:在META-INF下会有多余的以SF结尾的文件,删除后不会出现次问题 找到原因是因为引入的log4j版本有问题,当引入如下版本: log4j log4j 1.2.17 打包后不会出现如上问题 但我删除了META-INF下能看到的所有文件,打包时还是会生成还是会报错(因为是打包过程生成的); 然后又继续找答案,有说是rpc包版本冲突的,也...阅读全文

博文 2020-12-11 11:20:44 CSDN博客

spring中的@Transactional注解使用注意点_徐靖峰的专栏

@Transactional可以说是spring中最常用的注解之一了,通常情况下我们在需要对一个service方法添加事务时,加上这个注解,如果发生unchecked exception,就会发生rollback,最典型的例子如下。 @Service public class StudentService { @Autowired StudentDao studentDao; @Transactional public void innerSave(int i) { Student student = new Student(); student.setName("test" + i); studentDao.save(student); //i=5 会出现异常 int a = 1 / (i...阅读全文

博文 2020-10-16 22:51:29 CSDN博客

Java8中的“菱形继承”问题_潇兮水寒的博客

Java中的“菱形继承”问题 什么是菱形继承Java代码场景一场景二 简单结论解决办法 什么是菱形继承 一张图说明。在C++中允许多继承,D类继承自B、C,而B、C有同一个父类A。那么这个时候调用say方法是否成功?答案是不能,编译器并不能判断这个say来自哪个父类。 #include using namespace std; class A{ public: void say(){ cout<<"Say Hello"<阅读全文

博文 2021-06-11 21:43:50 CSDN博客_java菱形继承

MySQL案例:关于JSON的一个bug - 云+社区

前言周五晚上和朋友一起去外面吃饭,本来想着不加班早点回家过周末,谁又能想到突然就接到一个电话,mysqldump逻辑备份导入时报错,具体错误为“ERROR 3144 (22032): Cannot create a JSON value from a string with CHARACTER SET 'binary'.”下面就和大家简单分享一下这个案例,由于涉及业务数据,这里将通过自己模拟场景的方式来进行分享;关于真实场景或模拟场景分享,之前也说过,能够自己模拟复现出故障场景,往往才更加证明已经完全了解清楚其中的原理和解决办法。案例分享(1)创建一张含JSON列的表,并插入一条记录mysql> select version(); +------------+ | version() | +...阅读全文

博文 2021-06-02 19:25:31 腾讯云

Java 类隔离加载的正确姿势

什么是类隔离技术只要你 Java 代码写的足够多,就一定出现这种情况:系统新引入了一个中间件的 jar 包,编译的时候一切正常,一运行就报错:java.lang.NoSuchMethodError,然后就哼哧哼哧的开始谷歌找解决方法,最后在几百个依赖包里面找的眼睛都快瞎了才找到冲突的 jar,把问题解决之后就开始吐槽中间件为啥搞那么多不同版本的 jar,写代码五分钟,排包排了一整天。上面这种情况就是 Java 开发过程中常见的情况,原因也很简单,不同 jar 包依赖了某些通用 jar 包(如日志组件)的版本不一样,编译的时候没问题,到了运行时就会因为加载的类跟预期不符合导致报错。举个例子:A 和 B 分别依赖了 C 的 v1 和 v2 版本,v2 版本的 Log 类比 v1 版本新增了 er...阅读全文

博文 2021-10-22 10:10:23 知乎